Ubuntu Prerequisites (Packages to Install)

From SCIRun Documentation Wiki
Jump to navigation Jump to search

Ubuntu regression platform

We are currently testing on Ubuntu 11.10. We usually build SCIRun using the GCC C++ compiler, so we recommend installing the package that provides that compiler.

Ubuntu comes with a relatively minimal install, so several packages are required.

Ubuntu 12.x packages

Tested on Ubuntu 12.04. It is easy to get the necessary packages listed below via the Synaptic package manager or the command line instructions below:

sudo apt-get install subversion cmake-qt-gui cmake-curses-gui build-essential \
                     libxft-dev libxi-dev libxmu-headers freeglut3-dev \
                     libtiff4-dev

Ubuntu 11.x packages

Tested on Ubuntu 11.10 and 11.04. It is easy to get the necessary packages listed below via the Synaptic package manager or the command line instructions below:

sudo apt-get install subversion cmake-qt-gui cmake-curses-gui build-essential \
                     libxft-dev libxi-dev libxmu-headers freeglut3-dev \
                     libtiff4-dev

Ubuntu 10.x packages

Tested on Ubuntu 10.04 and 10.10. It is easy to get the necessary packages listed below via the Synaptic package manager or the command line instructions below:

sudo apt-get install subversion cmake-qt-gui cmake-curses-gui build-essential \
                     libxft-dev libxi-dev libxmu-headers libglut3-dev \
                     libtiff4-dev

CMake

CMake 2.8 or greater is required to build the SCIRun trunk.

CMake 2.6 or greater is required to build SCIRun versions 4.5 - 4.0.

Subversion

Version 1.6 or greater is recommended.

Ubuntu legacy support

Ubuntu 9.10 packages

It is easy to get the necessary packages listed below via the Synaptic package manager or the command line instructions below:

sudo apt-get install subversion cmake-gui cmake-curses-gui build-essential \
                     libxft-dev libxi-dev libxmu-headers libglut3-dev \
                     libtiff4-dev libpng12-dev

Ubuntu 8.10 packages

Ubuntu comes with a relatively minimal install and several packages may be required. It is easy to get the necessary packages listed below via the Synaptic package manager or the command line instructions below:

sudo apt-get install subversion cmake build-essential xlibs-dev libpng12-dev libxaw7-dev \
                     libglu1-mesa libc6-dbg libstdc++6-dbg libstdc++6-dev libglut3-dev